View All   Current page
Displays all thread messages Displays thread map That to which this responds This thread's lead message Your most recent Tavern page

Ubisoft strikes again!
05/08/2020, 17:15:53

    The Elf writes:

    I was happily playing along in MM10, when I ran into trouble. One of the main quest's requirements was to see a fellow about transportation to an area called The Elemental Forge, absolutely necessary to progress any further in the game. For some reason, when I talked to him, the option to ride with him never arose. (I'd played through the game at least four, if not six, times before, back in 2014-2016.) I rebooted, and tried again. No go. So I went to the Steam discussion section for the game, and looked up the question in their archives. Yes, there were several people who'd had the same difficulty. The answer was simple(?): you must be in something called Ubisoft Online, not just online.

    I think at this point I'll have a talk with the Steam Service people. Unless Ubisoft is looking to take over Steam, I don't believe it's even legal to insist on swapping services midstream.

    Anyway, caveat emptor. Avoid MM10 like the plague.

Reply to this message Back to the Tavern

Replies to this message